Cấu hình VLAN trên Switch Cisco, Hướng dẫn từ cơ bản đến nâng cao

Việc chia mạng LAN vật lý thành các mạng con ảo (VLAN) là một trong những công việc quan trọng để xây dựng và quản trị một hệ thống mạng doanh nghiệp hiệu quả. Tuy nhiên việc chia VLAN liên quan đến nhiều yếu tố kỹ thuật chuyên môn.

Trong bài viết này, Viễn Thông Xanh sẽ hướng dẫn bạn qua một loạt các bước cấu hình chia VLAN trên thiết bị Switch Cisco. Bạn sẽ được hướng dẫn từ những khái niệm cơ bản nhất như tạo VLAN và gán cổng, đến những tùy chỉnh phức tạp hơn như cấu hình Inter-VLAN Routing và sử dụng các tính năng bảo mật và quản lý VLAN. Bằng cách làm theo hướng dẫn từng bước và hiểu rõ từng khái niệm, bạn sẽ có kiến thức và kỹ năng cần thiết để xây dựng và quản lý một hệ thống mạng có cấu trúc VLAN mạnh mẽ trên Switch Cisco.

hướng dẫn cấu hình VLAN trên thiết bị Switch Cisco

Dù bạn là người mới bắt đầu trong lĩnh vực mạng hay đã có kinh nghiệm, bài hướng dẫn này sẽ cung cấp cho bạn một cái nhìn toàn diện về cách cấu hình VLAN trên Switch Cisco, từ cơ bản đến phức tạp.

Hãy chắc chắn rằng bạn đã hiểu VLAN là gì?

Như đã nói ở đầu bài viết, vì đây là một bài hướng dẫn kỹ thuật nên sẽ rất khó để bạn hình dung được nếu không hiểu VLAN là gì? Cũng như các khái niệm liên quan về chia mạng VLAN hay gặp.

Virtual Local Area Networks (VLANs) là công nghệ giúp chúng ta thực hiện điều này bằng cách tạo ra các mạng ảo trong mạng LAN vật lý, cho phép tách biệt lưu lượng dữ liệu và cải thiện sự quản lý và bảo mật.

minh họa mạng VLAN
minh họa mạng VLAN

Nếu bạn đã hiểu rõ khái niệm về VLAN thì chuyển tới phần tiếp theo về các bước hướng dẫn cấu hình. Còn nếu chưa hãy tìm hiểu qua các bài viết sau để hiểu rõ hơn về VLAN rồi quay lại bài viết này.

Xem thêm các bài viết về VLAN:

Cấu hình cơ bản chia VLAN trên Switch Cisco

Switch Cisco là một thiết bị mạng chuyển mạch thông minh, có khả năng tạo, quản lý và kiểm soát VLAN. Cấu hình trên Switch Cisco thường được thực hiện thông qua giao diện dòng lệnh.

Switch chia mạng Cisco 8 cổng Ethernet Gigabit + 2 cổng kết hợp SFPGigabit Ethernet - CBS250-8P-E-2G (2)
hình ảnh về Switch chia mạng Cisco

Tạo VLAN cơ bản

Mình sẽ bắt đầu bằng việc tạo một VLAN đơn giản trên Switch Cisco. Ví dụ, chúng ta sẽ tạo một VLAN có ID là 10 để sử dụng cho bộ phận kinh doanh.

enable
configure terminal
vlan 10
name Sales_VLAN
end
write memory

Giải thích:

  • enable“: Chuyển sang chế độ quản trị.
  • configure terminal”: Mở chế độ cấu hình.
  • vlan 10“: Tạo VLAN với ID 10.
  • name Sales_VLAN“: Đặt tên cho VLAN vừa tạo.
  • end“: Thoát khỏi chế độ cấu hình.
  • write memory“: Lưu cấu hình.

Gán cổng vào VLAN

Bắt đầu gán một cổng trên Switch Cisco vào VLAN mà bạn vừa tạo. Ví dụ, gán cổng 1/0/1 vào VLAN 10. Trong trường hợp này, 1/0/1 là tên cổng theo định dạng: số_slot/số_port. Đây là cách Switch Cisco xác định cổng vật lý.

enable
configure terminal
interface FastEthernet 1/0/1
switchport mode access
switchport access vlan 10
end
write memory

Ở đây:

  • interface FastEthernet 1/0/1“: Lệnh này xác định rằng bạn đang muốn cấu hình cổng FastEthernet với tên là 1/0/1.
  • switchport mode access” : Đặt cổng vào chế độ truy cập, điều này có nghĩa là cổng này sẽ kết nối trực tiếp với thiết bị hoặc máy tính.
  • switchport access vlan 10“: Lệnh này gán cổng vào VLAN 10, cho phép cổng này tham gia vào mạng ảo của VLAN 10.

Cấu hình VLAN theo nhu cầu cụ thể

Chia VLAN theo phòng ban

Giả sử bạn muốn tạo các VLAN cho các phòng ban khác nhau. Ví dụ, bạn muốn tạo VLAN cho IT, Nhân sự và Marketing. Các bạn thực hiện lệnh sau:

enable
configure terminal
vlan 20
name IT_VLAN
vlan 30
name Nhansu_VLAN
vlan 40
name Marketing_VLAN
end
write memory

Tiếp theo, gán các cổng vào các VLAN tương ứng theo hướng dẫn gán cổng mình đã nói ở phần trước.

Cấu hình Inter-VLAN Routing

Để cho phép giao tiếp giữa các VLAN, bạn cần cấu hình Inter-VLAN Routing. Hãy thực hiện theo lệnh sau:

enable
configure terminal
interface FastEthernet 1/0/24 (cổng kết nối với Router)
switchport mode trunk
end
write memory

Tiếp theo hãy tạo các subinterface trên Router và cấu hình định tuyến để cho phép giao tiếp giữa các VLAN.

Cấu hình VLAN Voice

Nếu bạn cần hỗ trợ Voice VLAN cho điện thoại IP hãy thực hiện cấu hình sau:

enable
configure terminal
vlan 50
name Voice_VLAN
end
write memory

Tiếp theo đó bạn cần gán cổng cho cả dữ liệu và Voice VLAN:

enable
configure terminal
interface FastEthernet 1/0/2
switchport mode access
switchport access vlan 20
switchport voice vlan 50
end
write memory

Hướng dẫn cấu hình quản lý và bảo mật VLAN

Bảo mật VLAN bằng Private VLAN

Để cách ly các cổng trong cùng một VLAN ta thực hiện lệnh sau:

enable
configure terminal
vlan 60
private-vlan isolated
vlan 70
private-vlan community
end
write memory

Gán cổng vào Private VLAN:

enable
configure terminal
interface FastEthernet 1/0/3
switchport mode private-vlan host
switchport private-vlan host-association 60 70
end
write memory

Quản lý VLAN bằng VLAN Management Policy Server (VMPS)

Sử dụng VMPS để quản lý tạo và xóa VLAN trên nhiều thiết bị:

enable
configure terminal
vmps
!
vmps server
!
vmps server primary
ip address <địa chỉ IP VMPS>
!
vmps-domain <tên miền VMPS>
vlan 80
vlan 90
!
vmps-authorization
vmps-domain <tên miền VMPS>
switch <địa chỉ MAC Switch>
!
end
write memory

Tổng Kết:

Trong bài hướng dẫn này, mình và bạn đã tiến xa hơn trong việc khám phá và thực hiện cấu hình chia VLAN trên Switch Cisco. Từ những khái niệm cơ bản như tạo và gán cổng VLAN cho đến các tùy chỉnh phức tạp như Inter-VLAN Routing, Private VLANs và VMPS. Bài viết này đã mang lại một cái nhìn toàn diện về cách tạo và quản lý mạng ảo trong mạng vật lý.

Qua hướng dẫn này, bạn đã học cách tận dụng tiềm năng của VLAN để cải thiện hiệu suất, bảo mật và quản lý mạng. Việc chia VLAN cho phòng ban, cấu hình Voice VLAN, và thậm chí là sử dụng VMPS để quản lý VLAN trên nhiều thiết bị đã giúp bạn xây dựng một hệ thống mạng linh hoạt và tiện lợi.

Nhớ rằng, sự hiểu biết sâu hơn về VLAN và khả năng cấu hình trên Switch Cisco sẽ là một công cụ mạnh mẽ cho việc xây dựng và duy trì mạng một cách hiệu quả. Hãy áp dụng những kiến thức bạn đã học vào các tình huống thực tế, và luôn tự tin trong việc thực hiện cấu hình mạng theo yêu cầu cụ thể.

Viễn Thông Xanh hy vọng rằng hướng dẫn này đã giúp bạn có cái nhìn tổng quan và sâu sắc hơn về cách cấu hình chia VLAN trên Switch Cisco. Hãy luôn nỗ lực học hỏi và áp dụng kiến thức mới để trở thành một chuyên gia trong lĩnh vực mạng, giúp xây dựng và duy trì hệ thống mạng tốt nhất cho tổ chức của bạn.

Banner thiết bị mạng

Ngoài ra, nếu bạn chưa hiểu vấn đề nào đó, hay muốn mua các thiết bị mạng chính hãng Switch Cisco, bộ định tuyến Router,… Hãy liên hệ ngay với đội ngũ nhân viên tư vấn của Viễn Thông Xanh qua số Zalo hiển thị trên web hoặc để lại lời nhắn tại Ô Chat Nhanh phía bên phải màn hình!

Xem thêm bài viết hay khác:

Có nên sử dụng VLAN cho mạng gia đình ?

Hướng dẫn cấu hình Switch Cisco cơ bản – Phần 1

Mạng Hình Sao (Star Topology) Chi Tiết về Cấu Trúc, Ưu Điểm và Hạn Chế